记录OneinStack更换升级PHP版本迎合WordPress程序

运维技术229字数 394阅读1分18秒阅读模式

今天遇到一个朋友在使用WordPress程序维护网站中看到有提示PHP版本过低,需要升级PHP高级版本。毕竟对于当前的WordPress要求的PHP版本最低需要7.4,最高可以选择8.1或者更高。

这里,我们检查下当前的服务器PHP版本。他WEB环境用的是OneinStack一键包。

可以看到他当前的PHP用的是7.0版本,确实不符合WP的要求,当然网站是正常运转的。基于后续的升级需要,或者主题兼容,还是建议升级到PHP7.4。

这里,我们需要先卸载当前的PHP版本。

./uninstall.sh

然后根据提示可以看到选择PHP版本卸载。

然后我们正常再进行安装PHP。

./install.sh

这里根据提示,其他软件都跳过不安装,选择PHP的安装具体的版本。

这里,我们等待安装结束如果没有任何报错就可以,最后我们也可以如上面检查当前的PHP版本即可。

如果我们不确定的话,可以提前服务器快照备份。

投上你的一票
 
麦子
  • 本文由 麦子 发表于 2023年5月6日 17:32:20
  • 转载请务必保留本文链接:https://www.idcxen.com/upgrade-ois-php.html
  • WordPress PHP版本
  • 升级PHP版本
  • OneinStack卸载PHP